If you upgraded to macOS Hight Sierra 10.13.x changes are Cydia Impactor is giving you this error when trying to install an app:
impactor

The text reads:

crypto-osx.cpp:97
The user name or passphrase you entered is not correct.

But beyond that there is no indication of what "user name" or "passphrase" impactor is referring to. I even tried to proxy the traffic with Burp but nothing in the traffic had that error, so I though it should be something local and that was exactly the case.

To fix this error just open the Keychain.app and click on the lock in the upper left corner:

keychain

Then just click it again to unlock it. That's it! now you should be able to install your app with Cydia Impactor.

There is something on macOS Hight Sierra preventing processes (like Cydia Impactor) from accessing the Keychain items.